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ภาคผนวก

ภาคผนวก ก ขั้นตอนการออกแบบพัฒนาวงจรตัวควบคุมไมโครคอนโทรลเลอรตระกูล AVR เบอร
90S8535

สํ าหรับการออกแบบวงจรตัวควบคุมไมโครคอนโทรลเลอร จะใชภาษาบรรยายฮารดแวร
หรือภาษาแอสแซมบลี้(Assembly Language Program) ซ่ึงเปนภาษาระดับตํ่ ามีความยุงยากเมื่อเทียบ
กบัภาษาซ ีแตมีขอดีคือ ควบคุมการทํ างานในระดับฮารดแวรไดงาย มีความเร็วสูง และโปรแกรมมี
ขนาดเล็ก สํ าหรับการออกแบบในสวนวงจรตัวควบคุม ในการบรรยายลักษณะการทํ างานของ
ดิจิตอลฮารดแวรจะบรรยายเชิงพฤติกรรม (Behavioral description) หรืออธิบายความสัมพันธ
ระหวางอินพุตกับเอาทพุท โดยผูออกแบบไมจํ าเปนตองรูถึงรายละเอียดของวงจรวาประกอบดวย
เกตชนิดใดเพียงแตรูหนาที่การทํ างานและความสัมพันธระหวางอินพุตและเอาทพุตของวงจรที่
ตองการออกแบบ ขั้นตอนการพัฒนาออกแบบตัวควบคุมประกอบดวยขั้นตอนหลักคือ ขั้นตอนการ
การใชซอฟตแวรหรือตัวคอมไฟเลอร (Compiler) และขั้นตอนการดาวนโหลดลงอุปกรณเปาหมาย
(Target device) คือชิพ AVR เพื่อโปรแกรมการทํ างาน (Configuration) ซ่ึงทั้งสองขั้นตอนนี้มีราย
ละเอียดและวิธีการพัฒนาดังนี้

1. แนะนํ าการใชโปรแกรม Astudio4 (AVR assembler)
สํ าหรับในหัวขอนี้เราจะอธิบายถึงวิธีการใชงานโปรแกรม Astudio4 เวอรช่ัน 4.05 อยาง

งาย นั่นคือเราจะอธิบายเฉพาะการใช text editer และวิธีการคอมไพลโปรแกรมเทานั้น แตในสวน
อ่ืนเชนการ debug program, chip simulator หากทานใดสนใจก็สามารถศึกษาไดจากเมนู Help

สํ าหรับโปรแกรมนี้มันสามารถทํ างานไดบนวินโดวส 9x/ME/NT/2000/XP ดงันั้นจึงไมมี
ปญหาใดๆสํ าหรับผูใชระบบปฏิบัติการที่ตางชนิดกัน การติดตั้งโปรแกรมก็ทํ าไดไมยาก  ซ่ึง
สามารถดาวนโหลดไดที่ www.Atmel.comโดยใหทานคลายไฟล Astudio4(zip file)ออกมา จากนั้น
ก็รันไฟล setup.exe และกท็ ําตามขั้นตอนที่แนะนํ าไปเรื่อยๆ จนการติดตั้งเสร็จสมบูรณ ซ่ึงหลังการ
ตดิตัง้โปรแกรมนี้มันก็พรอมที่จะทํ างานทันทีโดยเราไมตองเสียเวลารีสตารตเครื่องใหม
System requirement

- โปรแกรมนี้รันบนระบบปฏิบัติการ windows 9x/ME/NT/2000/XP
- ความเร็วของ CPU Intel Pentium 200 MHz
- ความละเอียดหนาจอไมควรตํ่ ากวา 800x600 pixels
- แรม 64 MB
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- ทีว่างฮารดดิสก 15 MB ขึ้นไป
1.1 การสรางไฟลโปรเจ็กตและไฟลอ่ืน ๆ

ถาการติดตั้งถูกตอง เมื่อเราเปดโปรแกรมนี้ขึ้นมา เราจะพบหนาตาง Welcome to
AVR Studio4 ดังนี้

สามารถเป
จะแสดงเป
สามารถท
มือของหน
ตอไปทาน
ออปชั่น P
โปรเจ็กตใ
นี้
ภาพประกอบ ก1 หนาตาง Welcome to AVR Studio 4

หนาตางนี้จะมีไวสํ าหรับใหเราสามารถทํ าการสรางโปรเจ็กตไฟลใหมหรือ
ดโปรเจ็กตไฟลที่มีอยูแลวได โปรเจ็กตไฟลจะมีนามสกุลเปน .aps สํ าหรับหนาตางนี้มัน
นอันดับแรกของการเปดโปรแกรมทุกครั้ง หากเราไมตองการใหมันแสดงหนาตางนี้ เรา
ํ าไดโดยการคลิกเมาส 1 คร้ังที่เช็คบล็อกShow this dialog on open ทีอ่ยูทางดานลางซาย
าตางนี้ เพื่อเอาเครื่องหมายถูกที่กาอยูในเช็คบล็อกออกไป ซ่ึงในการเปดโปรแกรมครั้ง
จะไมพบหนาตางนี้อีก และการเปดหรือสรางโปรเจ็กตใหมเราสามารถทํ าไดผานทาง
roject ทีอ่ยูในเมนูบารแทน แตสํ าหรับการอธิบายในที่นี้เราจะใชหนาตางนี้ในการสราง
หม โดยใหทานคลิกที่ปุม Create New Project ซ่ึงทานจะพบกับหนาตางใหมดังรูปตอไป
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โปรแกร
File จาก
โปรเจ็ก
ช่ือไฟล
แอสเซม
สามารถ

คอมไพ
ตั้งชื่อไฟ
จะไดไฟ

สามารถ
เช็คบ็อก
ชองขอค
เกบ็ไฟล
         ภาพประกอบ ก2 หนาตางทีใ่ชในการสรางโปรเจ็กตไฟล

ในขณะที่ทํ าการสรางไฟลโปรเจ็กต โปรแกรมสามารถที่จะสรางไฟล .asm ซ่ึงเปนไฟล
มภาษาแอสเซมบลีไดพรอมกันไปในตัวโดยการกาเครื่องหมายถูกที่เช็คบ็อก Create Initial 
นั้นใหเราพมิพช่ือไฟลโปรเจ็กตที่ชองขอความ Project Name ในตวัอยางเราจะใชช่ือไฟล
ต rs232 และในระหวางที่เราพิมพช่ือไฟลโปรเจก็ต เราจะสังเกตุเห็นวาโปรแกรมจะพิมพ
โปรเจ็กตลงที่ชองขอความ Initial File ไปดวย ซ่ึงจะเปนการสรางไฟลโปรแกรม .asm (ไฟล
บลี) และหากเราตองการใหโปรแกรมสรางไฟล .asm ทีม่ช่ืีอตางจากชื่อไฟลโปรเจ็กต เราก็
แกไขชื่อไฟล .asm ไดที่ชองขอความ Initial File นี้
ขอควรระวังในการตั้งชื่อไฟลแอสเซมบลีตางจากชื่อไฟลโปรเจ็กตนั่นก็คือ เมื่อเราทํ าการ
ลแลวไฟลตางๆ ทีโ่ปรแกรมทํ าการสรางขึ้นมามันจะตั้งชื่อตามชื่อไฟลโปรเจ็กตเชน ถาเรา
ลโปรเจ็กตเปน Testproject และเราตั้งชื่อไฟลแอสเซมบลีช่ือ rs232 หลังการคอมไพลเรา
ล Testproject.hex ดงันี้เปนตน
หากเราไมตองการใหมันสรางไฟลโปรแกรม .asm ขึน้ในขณะที่เราสรางไฟลโปรเจ็กต เรา
ทํ าไดโดยการคลิกที่เช็คบ็อก Create Initial File เพือ่เอาเครื่องหมายถูกที่กาอยูออก สวนที่
 Create Folder จะเปนการสรางโฟลเดอรขึ้นมาเพื่อเก็บไฟลโปรเจ็คไวนั่นเอง ถัดลงมาที่
วาม Location จะเปนตํ าแหนงของไฟลโปรเจ็คที่จะถูกนํ าไปเก็บ ซ่ึงเราสามารถเลือกที่จะ
ที่ใหมไดโดยการคลิกที่ปุม  ทีอ่ยูทายชองรับความหรือพิมพช่ือ path ลงไปเลยก็ไดเชน
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เดยีวกนั สํ าหรับในตัวอยางนี้เราจะเก็บไฟลโปรเจ็กตไวที่ C:\My Documents\avr และทํ าการสราง
ไฟล .asm ขึน้พรอมกับการสรางไฟลโปรเจ็กตดวย

เมื่อทุกอยางถูกตองดีแลวก็ใหเราทํ าการคลิกที่ปุม Finish เพื่อจะเขาหนาจอ text editor 
สํ าหรับเขียนโปรแกรมตอไป หนาจอที่เกิดขึ้นใหมหลังการกดปุม Finish แสดงไดดังรูปตอไปนี้ 
(ถาเรากดปุม Next โปรแกรมจะใหเราเลือก paltform และ MCU ทีเ่ราจะใชในการซมิมูเลตและ  
debug โปรแกรม ตอไป)

จ
ไฟลในโป
หนาตางถ
Output ท
พบหนาต
Work space
ภาพประกอบ ก3 หนาจอ

ากภาพประกอบ ก3 จะประกอบไปดวยห
รเจ็กตเชนการ Add existing file, Remov
ัดมาคือ Text Editor มไีวสํ าหรับใหเรา
ีท่ ําหนาที่แสดงขอความบอกใหเราทราบถ
างทั้งสามนี้ทานสามารถเปดมันขึ้นมาไดเอ
Text Editor
ที่เ

น
e 
เข
ึงผ
ง

Output
กิดขึ้นหลังการกดปุม Finish

าตาง Work space ซ่ึงมีไวสํ าหรับจัดการกับ
File หรือ การ Set as Entry File เปนตน สวน
ียนโปรแกรมลงไป และสุดทายเปนหนาตาง 
ลจากการคอมไฟลโปรแกรม ซ่ึงหากทานไม

 โดยการเขาไปเลือกที่เมนู View
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เมื่อเราทํ าการเขียนโปรแกรมลงไปที่ text editor เรียบรอยแลวก็ใหทํ าการบันทึกไฟลโดย
การเลือกไปที่เมนู File>save และทํ าการคอมไพลโปรแกรมโดยการกดปุม F7 หรือเลือกที่เมนู 
Project>Build หากเราเขียนโปรแกรมถูกตอง โปรแกรมจะไมฟอง Error ทีห่นาตาง Output แตหาก
เขยีนโปรแกรมไมถูกตองมันจะฟอง Error หรือ Warning กใ็หเราแกไขมันใหถูกตองและทํ าการ
คอมไพลใหมซ่ึงจะทํ าใหไดไฟล rs232.aps, rs232.hex, rs232.lst, rs232.map, rs232.asm และ 
rs232.obj ขึ้นมา หากเราไมตองการไฟล .map และ .lst ใหเราเขาไปที่เมนู Project>AVR Asembler 
Setup จากนั้นจะพบหนาตาง AVRAssembler  ใหเราคลิกเอาเครื่องหมายถูกที่ชอง Map File กับ Lst 
File ออกและจากนั้นก็กดปุม Ok กเ็ปนอันเสร็จสิ้น สํ าหรับไฟลนามสกุลตางๆ ดังที่เรากลาวมาขาง
ตนทานสามารถเปดเขาไปดูเนื้อหาขางในไฟลไดดวยการเลือกไปที่เมนู File>Open File จากนั้นก็
เลือกไฟลที่ทานตองการเปดและกดปุม Open

     ภาพประกอบ ก4 หนาตาง AVRAssembler
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1.2 การเปดไฟลโปรเจ็กตและไฟลแอสเซมบลี
เมื่อเราตองการเปดโปรแกรมที่มีอยูแลวขึ้นมาแกไขเราสามารถทํ าไดโดยการคลิก

เมนู Project>Open Project เพือ่เปนการเปดไฟลโปรเจ็กต(*.aps) หลังจากที่เราเปดไฟลโปรเจ็กต
แลวจากนั้นก็คลิกเลือกไปที่โฟลเดอร Assembler ทีอ่ยูในหนาตาง Work space เราจะพบไฟล .asm 
ทีเ่ราตองการแกไขอยูในนั้น แตถาหากเราเปดไฟลโดยใชเมนู File>Open File เราก็สามารถที่จะเปด
ไฟล .asm(หรือไฟลอ่ืนๆ ที่ text editor รองรับ) ไดเชนเดียวกัน แตเราจะไมสามารถทํ าการคอมไพล
มันได เปนไดแตเพียงการแกไขและบันทึกเทานั้น อยางไรก็ตามการเปดไฟลโปรเจ็กต(*.aps) ดวย
เมนู File>Open File นี้ก็สามารถทํ าไดและใหผลการทํ างานเชนเดียวกับการเปดมันดวยเมนู
Project>Open Project

1.2.1 การ Add existing File, Remove File และ Set as Entry File
- Add existing File กค็อืการเพิ่มไฟล .asm เขามาในโปรเจ็กต โดยเรา

สามารถทํ าได 2 วิธีดวยกันคือการเลือกไปที่เมนู Project>Add existing File จากนั้นก็ใหเราเลือก
ไฟล .asm ที่เราตองการนํ าเขามา สวนอีกวิธีหนึ่งทํ าไดโดยการคลิกเมาสปุมขวาไปที่โฟลเดอร 
Assembler ทีอ่ยูในหนาตาง Work space จากนัน้เราจะเห็นหนาตางออปชัน่เล็กๆ ปรากฏขึ้นมาก็ให
เราเลื่อนเมาสไปคลิกเลือกที่ Add existing File จะทํ าใหเราสามารเลือกไฟล .asm ที่เราตองการได

- Remove File จะทํ างานตรงกันขามกับ Add existing File นัน่คือมันจะ
ลบไฟล .asm ทีเ่ราไมตองการออกจากโปรเจ็กตไฟลของเรา เราสามารถ Removeไฟลไดโดยการ
คลิกเมาสปุมขวาเลือกไปที่ไฟลที่เราตองการลบ จากนั้นจะปรากฏหนาตางขึ้นมาใหเราเลือกไปที่ 
Remove File form Project เพยีงเทานี้ไฟลที่เราเลือกมันก็จะถูกลบออกไปจากโปรเจ็กตที่เรากํ าลัง
ทํ างานอยู

- Set as Entry File จะเปนการเลือกไฟล .asm ทีอ่ยูในโปรเจ็กตไฟลขณะ
นัน้ใหมันพรอมที่จะถูกคอมไพล ฟงกช่ันนีจ้ะมีความจํ าเปนมากเมื่อเรามีไฟล .asm หลายไฟลอยูใน
โปรเจ็กตเดียวกัน ซ่ึงโปรแกรม Astudio4 นีจ้ะไมทํ าการคอมไพลไฟล .asm ทัง้หมดพรอมกัน แต
จะเลือกคอมไพลเฉพาะไฟลที่โดน Set as Entry File เทานั้น เราสามารถรูไดวาไฟล .asm ตวัใดที่ถูก 
set ไวโดยการสังเกตไอคอนที่อยูหนาชื่อไฟลจะมีรูปลูกศรสีแดงหันหัวลงดังนี้  หรือดูไดจาก
ภาพประกอบ ก5
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ภาพ
         
         

จะตอ
เสร็จ 
ตามใ
มนัจะ
ไฟล .

ไรบา
ขนาด
โปรแ
“C:\M
detect
ประกอบ ก5 หนาจอที่เกิดจากการ Add existing File และหนาตาง Output ที่รายงานผลการ
                       คอมไพลโปรดสังเกตการ Warning (วงกลมสีเหลือง) ตางๆดวย ถึงแมการ
                       คอมไพลไมผิดพลาดแตอาจจะมีผลตอการทํ างานของ CPU ได

สํ าหรับการ Set as Entry File สามารถทํ าไดโดยการคลิกเมาสปุมขวาเลือกไปที่ช่ือไฟลที่เร
งการคอมไพลจากนั้นจะปรากฏเมนูเล็กๆ ขึ้นมาใหเราเลือกไปที่ Set as Entry File กเ็ปนอัน
เราควรจํ าไวอยางหนึ่งวาหลังการคอมไพลแลวไมวาเราจะทํ าการคอมไพลไฟล .asm ตัวใดก็
นโปรเจ็กตนั้น ไฟลเอาพุตที่โปรแกรมสรางขึ้นมานั้นจะมีช่ือตามชื่อไฟลโปรเจ็กตนั้นเสมอ 
ไมมีช่ือไฟลตามไฟล .asm ทีถู่กคอมไฟล ดังนั้นเพื่อปองกันการสับสนทานอาจจะใหมีเพียง
asm เพยีงไฟลเดียวอยูในไฟลโปรเจ็กตแตละโปรเจ็กตก็ไดและตั้งชื่อใหทั้งสองไฟลนี้ตรงกัน
อีกอยางหนึ่งที่อยากจะใหสังเกต นั่นก็คือผลที่ไดจากการคอมไพลในแตละครั้งวาเปนเชน

งเชน ขนาดของไฟลที่คอมไพลไดมีขนาดเทาไรซึ่งบางทีเราเขียนโปรแกรมเพลินมันอาจจะมี
โตกวาหนวยความจํ าที่จะเก็บมันก็ได หรือที่สํ าคัญอีกอยางหนึ่งก็คือขอความ Warning ที่
กรมเตือนดังนี้
y Documents\avr\rs232.asm(92): warning: A .db segment with an odd number of bytes is
ed. A zero byte is added.”
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หากทานใดเคยเลน AVR และใชฟงกช่ันที่เกี่ยวกับพอรตอนุกรม RS232 คงพอจะทราบดี
วาบางครั้ง AVR มันก็ไมสามารถแสดงขอความที่อยู หลังบรรทัดนี้(บรรทัดที่แสดงขอความ 
Warning) ตอไปได ทั้งที่ขอความยังไมส้ินสุด นัน่เปนเพราะวามันจะทํ าการเขียนขอมูลลงหนวย
ความจํ าโปรแกรมเปนทีละ word(2 ไบต) ดงันัน้เมือ่ขอความที่เราตองการจะเขียนลงบนหนวยความ
จ ํามนัมีจํ านวนเปนเลขคี่ มันก็จะเพิ่มเลข 0 เขาไปทายขอความในบรรทัดนั้นๆ เพื่อใหครบจํ านวน
เปนเลขคูเสมอ  ทนีีเ้มื่อเราเขียนโปรแกรมใหตรวจสอบขอความวาถาพบเลข  0 เมื่อใดก็ใหถือวาสิ้น
สุดขอความทันที ดังนั้นเมื่อโปรแกรมทํ าการอานและตรวจสอบขอมูลมาถึงไบตที่ AVR เพิ่มเลข 0 
ขึ้นมาเอง โปรแกรมก็เขาใจวาเราตองการสิ้นสุดขอความที่บรรทัดนี้ดังนั้นจึงทํ าใหขอความที่เหลือ
ไมถูกตรวจพบนั่นเอง และวิธีแกงายๆ นั่นก็คือใหเราเพิ่มอักขระอะไรก็ไดเขาไปอีกตัวหนึ่งใน
บรรทัดนี้ยกเวนเลข 0 เทานี้ก็สามารถแกการ warning ตรงนีไ้ด(เลข 0 ที่เรากํ าลังพูดถึงกันอยูขณะนี้
ไมใชเลข “0” ที่เปนรหัส ASCII นะครบัหากแตเปนเลข 0 ที่เปนเซตของเลขจํ านวนเต็ม)

2. แนะนํ าการใชโปรแกรม w95s8535v5
สํ าหรับในหัวขอนี้จะอธิบายถึงวิธีการใชงานโปรแกรม w95s8535v5 เวอรช่ัน 5 โดยจะ

อธิบายวิธีการดาวนโหลดโปรแกรมที่ผานการคอมไพลโปรแกรมแลวลงบนชิปเพื่อใชงานตาม
ความตองการของผูใช

สํ าหรับโปรแกรมนี้สามารถทํ างานไดบนวินโดวส 9x/ME/NT/2000/XP ดังนั้นจึงไมมี
ปญหาใดๆสํ าหรับผูใชระบบปฏิบัติการที่ตางชนิดกัน ซ่ึงโปรแกรมดังกลาวเปนของบริษัทอีทีที 
สามารถดาวนโหลดไดที่ www.ett.co.th การตดิตั้งโปรแกรมก็ทํ าไดไมยาก หลังจากดาวนโหลด
ไฟลเสร็จแลว สามารถรันโปรแกรมใชไดทันที่ โดยในการรันโปรแกรมใชคร้ังแรก จะตองเซ็ต
เลือกตํ าแหนงพอรตสํ าหรับการโหลดโปรแกรมใน Frame Static ในภาพประกอบ ก6 ไดเลือกใช
พอรต Lpt1



100

ภาพประกอบ ก6 แสดงหนาตางโปรแกรม w95s8535v5

สํ าหรับหนาตางนี้มันจะแสดงเปนอันดับแรกของการเปดโปรแกรมทุกครั้ง หลังจากนั้น
เลือกคลิกปุม                       ซ่ึงจะแสดง Path ของ window ขึน้มาจากนั้นทํ าการเลือกไฟล
โปรแกรมที่คอม
โปรแกรมในสวน
ซ่ึงหมายความวา

Set port
Lpt1
  

ไฟลแลว ซ่ึงไฟลจะมีนามสกุลเปน .HEX  หลังจาก Open Hex File แลวหนาตาง

 Text ดานลางสุดจากที่แสดงขอความ 0% จะแสดงขอความ Load Hex File Ok 
 โปรแกรมพรอมที่จะทํ าการโหลดไฟลลงบนอุปกรณแลว
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ภาพประกอบ ก7 แสดงหนาตางเมื่อทํ าการ Open File .Hex

หลังจากที่ทํ าการเปดไฟล .Hex เสรจ็เรียบรอยแลวก็มาถึงขั้นตอนการโหลดโปรแกรมลง
บนชิพ ซ่ึงจะตองทํ าการตรวจสอบการตอพอรตและเปดไฟเลี้ยงจายแกบอรดอุปกรณใหเรียบรอย 
หลังจากนั้นกดปุม                        เพือ่ทํ าการโหลดโปรแกรมลงบนชิพเพือ่นํ าไปใชงานตอไป ใน
ขบวนการโหลดเมื่อโปรแกรมโหลดขอมูลเสร็จจะแสดงขอความบอกดังภาพประกอบ

ภาพประกอบ ก8 แสดงหนาตางเมื่อโหลดโปรแกรมลงบนชิพ

Open File .Hex
Ok
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ภาคผนวก ข โปรแกรมรหัสตนฉบับภาษาแอสแซมบลี้สํ าหรับการออกแบบควบคุม

ลํ าดับการแสดงโปรแกรมรหัสตนฉบับของการออกแบบมีดังนี้
1. สวนควบคุมการสรางสัญญาณใหพอรตขนานในโหมดการทํ างานแบบ EPP

(EPPSigCntl)
2. สวนการสรางสัญญาณควบคุมโหมดการเขียนและอาน ADC
3. สวนการรับและสงขอมูลดิจิตอลเขาสูเครื่องคอมพิวเตอรผานพอรตขนาน



103

การนิยามตํ าแหนงรีจิสเตอรอินพุทเอาทพุท (I/O Register Definitions)
ในการพัฒนาโปรแกรมจะมีการอางชื่อไฟล (File name) เร่ิมตนกอนที่จะเขียนโปรแกรม

พฒันางานตามความตองการของผูใชคือไฟล "8535def.inc" โดยในการพัฒนาโปรแกรมจะเริ่มตน
โปรแกรมคือ .include "8535def.inc" ซ่ึงหมายถึง การรวมไฟล  "8535def.inc" ทั้งหมดเขาใน
โปรแกรมนี ้ โดยในไฟลนี้จะประกอบไปดวย การนิยามคาตํ าแหนงตางๆของรีจีสเตอรอินพุทเอาท
พทุ โดยตํ าแหนงของชื่อรีจสิเตอรจะนิยามคาเปนเลขฐาน 16 (hexadecimal)  และตํ าแหนงของบิท
จะนยิามคาเปนเลข 0-7 โดยรายละเอียดการนิยามตํ าแหนงรีจิสเตอรอินพทุเอาทพุทมีดังนี้

;***** I/O Register Definitions******
.equ SREG = $3f
.equ SPH = $3e
.equ SPL = $3d
.equ GIMSK = $3b
.equ GIRF = $3a
.equ TIMSK = $39
.equ TIFR = $38
.equ MCUCR = $35
.equ MCUSR = $34
.equ TCCR0 = $33
.equ TCNT0 = $32
.equ TCCR1A = $2f
.equ TCCR1B = $2e
.equ TCNT1H = $2d
.equ TCNT1L = $2c
.equ OCR1AH = $2b
.equ OCR1AL = $2a
.equ OCR1BH = $29
.equ OCR1BL = $28
.equ ICR1H = $27
.equ ICR1L   = $26
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.equ TCCR2 = $25

.equ TCNT2 = $24

.equ OCR2 = $23

.equ ASSR    = 22

.equ WDTCR = $21

.equ EEARH = $1f

.equ EEARL = $1e

.equ EEDR = $1d

.equ EECR = $1c

.equ PORTA = $1b

.equ DDRA = $1a

.equ PINA = $19

.equ PORTB = $18

.equ DDRB = $17

.equ PINB = $16

.equ PORTC = $15

.equ DDRC = $14

.equ PINC = $13

.equ PORTD = $12

.equ DDRD = $11

.equ PIND = $10

.equ SPDR = $0f

.equ SPSR = $0e

.equ SPCR = $0d

.equ UDR = $0c

.equ USR = $0b

.equ UCR = $0a

.equ UBRR = $09

.equ ACSR = $08

.equ ADMUX  = $07
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.equ    ADCSR  = $06

.equ    ADCH    = $05

.equ    ADCL    = $04

;***** Bit Definitions*****
.equ INT1 = 7
.equ INT0 = 6

.equ TOIE1 = 7

.equ OCIE1A = 6

.equ OCIE1B = 5

.equ TICIE = 3

.equ TOIE0 = 1

.equ TOV1 = 7

.equ OCF1A = 6

.equ OCF1B = 5

.equ ICF1 = 3

.equ TOV0 = 1

.equ SRE = 7

.equ SRW = 6

.equ SE = 5

.equ SM = 4

.equ ISC11 = 3

.equ ISC10 = 2

.equ ISC01 = 1

.equ ISC00 = 0

.equ CS02 = 2
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.equ CS01 = 1

.equ CS00 = 0

.equ COM1A1 = 7

.equ COM1A0 = 6

.equ COM1B1 = 5

.equ COM1B0 = 4

.equ PWM11 = 1

.equ PWM10 = 0

.equ ICNC1 = 7

.equ ICES1 = 6

.equ CTC1 = 3

.equ CS12 = 2

.equ CS11 = 1

.equ CS10 = 0

.equ PWM2    = 6

.equ    COM21 = 5

.equ    COM20   = 4

.equ    CTC2 = 3

.equ    CS22 = 2

.equ CS21 = 1

.equ    CS20 = 0

.equ AS2 = 3

.equ TCN2UB = 2

.equ OCR2UB  = 1

.equ    TCR2UB = 0
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.equ WDTOE = 4

.equ WDE = 3

.equ WDP2 = 2

.equ WDP1 = 1

.equ WDP0 = 0

.equ EEAR8 = 0

.equ EEWE = 1

.equ EERE = 0

.equ PA7 = 7

.equ PA6 = 6

.equ PA5 = 5

.equ PA4 = 4

.equ PA3 = 3

.equ PA2 = 2

.equ PA1 = 1

.equ PA0 = 0

.equ DDA7 = 7

.equ DDA6 = 6

.equ DDA5 = 5

.equ DDA4 = 4

.equ DDA3 = 3

.equ DDA2 = 2

.equ DDA1 = 1

.equ DDA0 = 0

.equ PINA7 = 7
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.equ PINA6 = 6

.equ PINA5 = 5

.equ PINA4 = 4

.equ PINA3 = 3

.equ PINA2 = 2

.equ PINA1 = 1

.equ PINA0 = 0

.equ PB7 = 7

.equ PB6 = 6

.equ PB5 = 5

.equ PB4 = 4

.equ PB3 = 3

.equ PB2 = 2

.equ PB1 = 1

.equ PB0 = 0

.equ DDB7 = 7

.equ DDB6 = 6

.equ DDB5 = 5

.equ DDB4 = 4

.equ DDB3 = 3

.equ DDB2 = 2

.equ DDB1 = 1

.equ DDB0 = 0

.equ PINB7 = 7

.equ PINB6 = 6

.equ PINB5 = 5

.equ PINB4 = 4
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.equ PINB3 = 3

.equ PINB2 = 2

.equ PINB1 = 1

.equ PINB0 = 0

.equ PC7 = 7

.equ PC6 = 6

.equ PC5 = 5

.equ PC4 = 4

.equ PC3 = 3

.equ PC2 = 2

.equ PC1 = 1

.equ PC0 = 0

.equ DDC7 = 7

.equ DDC6 = 6

.equ DDC5 = 5

.equ DDC4 = 4

.equ DDC3 = 3

.equ DDC2 = 2

.equ DDC1 = 1

.equ DDC0 = 0

.equ PINC7 = 7

.equ PINC6 = 6

.equ PINC5 = 5

.equ PINC4 = 4

.equ PINC3 = 3

.equ PINC2 = 2

.equ PINC1 = 1



110

.equ PINC0 = 0

.equ PD6 = 6

.equ PD5 = 5

.equ PD4 = 4

.equ PD3 = 3

.equ PD2 = 2

.equ PD1 = 1

.equ PD0 = 0

.equ DDD6 = 6

.equ DDD5 = 5

.equ DDD4 = 4

.equ DDD3 = 3

.equ DDD2 = 2

.equ DDD1 = 1

.equ DDD0 = 0

.equ PIND6 = 6

.equ PIND5 = 5

.equ PIND4 = 4

.equ PIND3 = 3

.equ PIND2 = 2

.equ PIND1 = 1

.equ PIND0 = 0

.equ SPIF = 7

.equ WCOL = 6

.equ SPIE = 7



111

.equ SPE = 6

.equ DORD = 5

.equ MSTR = 4

.equ CPOL = 3

.equ CPHA = 2

.equ SPR1 = 1

.equ SPR0 = 0

.equ RXC = 7

.equ TXC = 6

.equ UDRE = 5

.equ FE = 4

.equ OR = 3

.equ RXCIE = 7

.equ TXCIE = 6

.equ UDRIE = 5

.equ RXEN = 4

.equ TXEN = 3

.equ CHR9 = 2

.equ RXB8 = 1

.equ TXB8 = 0

.equ ACD = 7

.equ ACO = 5

.equ ACI = 4

.equ ACIE = 3

.equ ACIC = 2

.equ ACIS1 = 1

.equ ACIS0 = 0
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.equ    MUX0    = 0

.equ    MUX1    = 1

.equ    MUX2   = 2

.equ    ADPS0   = 0

.equ    ADPS1   = 1

.equ    ADPS2  = 2

.equ    ADIE   = 3

.equ    ADIF   = 4

.equ    ADFR    = 5

.equ    ADSC    = 6

.equ    ADEN    = 7

.def XL = r26

.def XH = r27

.def YL = r28

.def YH = r29

.def ZL = r30

.def ZH = r31

.equ    RAMEND = $20+$40+$1ff    ;Adjust for registers and I/O

.equ INT0addr = $001 ;External Interrupt0 Vector Address

.equ INT1addr = $002 ;External Interrupt1 Vector Address

.equ ICP1addr = $003 ;Input Capture1 Interrupt Vector Address

.equ OC1Aaddr = $004 ;Output Compare1A Interrupt Vector Address

.equ OC1Baddr = $005 ;Output Compare1B Interrupt Vector Address

.equ OVF1addr = $006 ;Overflow1 Interrupt Vector Address

.equ OC0addr = $007 ;Output Compare0 Interrupt Vector Address

.equ OVF0addr = $008 ;Overflow0 Interrupt Vector Address
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.equ SPIaddr = $009 ;SPI Interrupt Vector Address

.equ URXCaddr = $00a ;UART Receive Complete Interrupt Vector Address

.equ UDREaddr = $00b ;UART Data Register Empty Interrupt Vector Address

.equ UTXCaddr = $00c ;UART Transmit Complete Interrupt Vector Address

.equ ACIaddr  = $00d ;Analog Comparator Interrupt Vector Address
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;/*************************************************************************
; Program :Phonocardiogram the external ADC
; Description :convert analog input signal to 8 bit digital output.
; :The digital signal will be send to palalell port.
; Pin description :Digital input pin = PA7-PA0 : Output pin = PD7-PD0 : PC0 = wait : PC1 = WR
; :PB0 = Address strobe : PC2-PC5 Control signal decoder/demultiplexer to
; :G,A,B,C with RD1-RD8
; CPU Control :90S8535
; File name :Multiplex 8 channal.asm
; Assembler :AVR Studio 4.05
;**************************************************************************
.include "8535def.inc"

    .org $000
         rjmp RESET

.def temp  = r19

.equ koo = 0

.equ  kai = 1

RESET:       ldi temp,low(RAMEND)
               Out SPL,temp
            Ldi temp,high(RAMEND)
            Out SPL+1,temp         
;/***********************
; set port
;/***********************  

 ser r16
         out DDRC,r16

 cbi PORTC,koo
 out DDRD,r16
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 out PORTB,r16
 out PORTA,r16 
 ldi r16,0x00

         out DDRA,r16
         out DDRB,r16

 sbi PORTC,kai
 ldi r17,0b11000010
 out PORTC,r17

  ldi r16,0b10100010 ;ch1 start
  mov r1,r16
  ldi r16,0b10100110 ;ch2
  mov r2,r16
  ldi r16,0b10101010 ;ch3
  mov r3,r16
  ldi r16,0b10101110 ;ch4
  mov r4,r16
  ldi r16,0b10110010 ;ch5
  mov r5,r16
  ldi r16,0b10110110 ;ch6
  mov r6,r16
  ldi r16,0b10111010 ;ch7
  mov r7,r16
  ldi r16,0b10111110 ;ch8
  mov r8,r16

 ldi r16,0b01000010 ;ch1 end
 ldi r17,0b11000010 ;ch2
 ldi r21,0b11010110 ;ch3
 ldi r22,0b11011110 ;ch4
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 ldi r23,0b11001110 ;ch5
 ldi r24,0b11011110 ;ch6
 ldi r25,0b11011110 ;ch7
 ldi r26,0b11011110 ;ch8
 ldi r27,0xab
  

;/***********************************
; start convert multiplex 8 chanall
;/***********************************
a:      in     r18,PINB   ;wait logic 0 from palalell port
       cpi    r18,0xfe
     brne  a

 cbi  PORTC,kai ;ch1
 sbi  PORTC,kai ;write complet
 rcall  delay ;delay time 1.5us

b:  in           r18,PINB
         cpi         r18,0xfe
     brne  b

 out  PORTC,r1 ;start read
 nop
 nop
 nop
 In  r20,PINA ;read data r20
 out  PORTC,r16
 out  PORTD,r20 ;sent data to palalell ch1
 sbi  PORTC,koo
 cbi  PORTC,koo

c:  in    r18,PINB
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        cpi     r18,0xfe
     brne  c

 out PORTC,r2 ;ch2
 nop
nop
nop
in r20,PINA
out PORTC,r17
out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo

d: in     r18,PINB
        cpi     r18,0xfe
    brne  d

out  PORTC,r3 ;ch3
nop
nop
nop
in   r20,PINA
out   PORTC,r21
out   PORTD,r20
sbi   PORTC,koo
cbi   PORTC,koo

e: in       r18,PINB
        cpi      r18,0xfe
    brne   e

out   PORTC,r4 ;ch4
nop
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nop
nop
in  r20,PINA
out PORTC,r22
out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo

f: in           r18,PINB
      cpi         r18,0xfe
    brne f

out PORTC,r5 ;ch5
nop
nop
nop
in r20,PINA
out PORTC,r23
out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo

g: in   r18,PINB
        cpi   r18,0xfe
   brne g

out PORTC,r6 ;ch6
nop
nop
nop
in r20,PINA
out PORTC,r24
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out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo

h: in     r18,PINB
        cpi    r18,0xfe
    brne h

out PORTC,r7 ;ch7
nop
nop
nop
in r20,PINA
out PORTC,r25
out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo

i: in     r18,PINB
        cpi  r18,0xfe
    brne i

out PORTC,r8 ;ch8
nop
nop
nop
in r20,PINA
out PORTC,r26
out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo
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out PORTD,r27 ;sent ab
sbi PORTC,koo
cbi PORTC,koo
rjmp a

;/*************************
; delay time
;/*************************
delay : nop

nop
nop
nop
nop
ret
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ภาคผนวก ค.
ผลงานทาวิชาการ
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บทความเรื่อง

การพฒันาเครื่องตนแบบเพื่อเก็บบันทึกและวิเคราะหเสียงการเตนของหัวใจ
จากหลายตํ าแหนงบริเวณหนาอก

Development of a Prototype System for Recording and  Analysising of  Simultaneous
Phonocardiograms from Multiple chest sites.

  น ําเสนอในการประชุมเสนอผลงานวิจัยระดับบัณฑิตศึกษา มหาวิทยาลัยสงขลานครินทร คร้ังที่ 2


	ÀÒ¤¼¹Ç¡
	
	
	
	
	1.1 ¡ÒÃÊÃéÒ§ä¿Åìâ»Ãà¨ç¡µìáÅÐä¿Åì�





	1.2 ¡ÒÃà»Ô´ä¿Åìâ»Ãà¨ç¡µìáÅÐä¿Åìá�
	ÀÒ¤¼¹Ç¡ ¢ â»Ãá¡ÃÁÃËÑÊµé¹©ºÑºÀÒÉ�
	
	
	
	¼Å§Ò¹·ÒÇÔªÒ¡ÒÃ



	º·¤ÇÒÁàÃ×èÍ§
	
	
	
	¡ÒÃ¾Ñ²¹Òà¤Ã×èÍ§µé¹áººà¾×èÍà¡çº�
	¨Ò¡ËÅÒÂµÓáË¹è§ºÃÔàÇ³Ë¹éÒÍ¡
	Development of a Prototype System for Recording and  Analysising of  Simultaneous Phonocardiograms from Multiple chest sites.



	¹ÓàÊ¹Íã¹¡ÒÃ»ÃÐªØÁàÊ¹Í¼Å§Ò¹ÇÔ¨Ñ�




