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ภาคผนวก

ภาคผนวก ก ขั้นตอนการออกแบบพัฒนาวงจรตัวควบคุมไมโครคอนโทรลเลอรตระกูล AVR เบอร
90S8535

สํ าหรับการออกแบบวงจรตัวควบคุมไมโครคอนโทรลเลอร จะใชภาษาบรรยายฮารดแวร
หรือภาษาแอสแซมบลี้(Assembly Language Program) ซ่ึงเปนภาษาระดับตํ่ ามีความยุงยากเมื่อเทียบ
กบัภาษาซ ีแตมีขอดีคือ ควบคุมการทํ างานในระดับฮารดแวรไดงาย มีความเร็วสูง และโปรแกรมมี
ขนาดเล็ก สํ าหรับการออกแบบในสวนวงจรตัวควบคุม ในการบรรยายลักษณะการทํ างานของ
ดิจิตอลฮารดแวรจะบรรยายเชิงพฤติกรรม (Behavioral description) หรืออธิบายความสัมพันธ
ระหวางอินพุตกับเอาทพุท โดยผูออกแบบไมจํ าเปนตองรูถึงรายละเอียดของวงจรวาประกอบดวย
เกตชนิดใดเพียงแตรูหนาที่การทํ างานและความสัมพันธระหวางอินพุตและเอาทพุตของวงจรที่
ตองการออกแบบ ขั้นตอนการพัฒนาออกแบบตัวควบคุมประกอบดวยขั้นตอนหลักคือ ขั้นตอนการ
การใชซอฟตแวรหรือตัวคอมไฟเลอร (Compiler) และขั้นตอนการดาวนโหลดลงอุปกรณเปาหมาย
(Target device) คือชิพ AVR เพื่อโปรแกรมการทํ างาน (Configuration) ซ่ึงทั้งสองขั้นตอนนี้มีราย
ละเอียดและวิธีการพัฒนาดังนี้

1. แนะนํ าการใชโปรแกรม Astudio4 (AVR assembler)
สํ าหรับในหัวขอนี้เราจะอธิบายถึงวิธีการใชงานโปรแกรม Astudio4 เวอรช่ัน 4.05 อยาง

งาย นั่นคือเราจะอธิบายเฉพาะการใช text editer และวิธีการคอมไพลโปรแกรมเทานั้น แตในสวน
อ่ืนเชนการ debug program, chip simulator หากทานใดสนใจก็สามารถศึกษาไดจากเมนู Help

สํ าหรับโปรแกรมนี้มันสามารถทํ างานไดบนวินโดวส 9x/ME/NT/2000/XP ดงันั้นจึงไมมี
ปญหาใดๆสํ าหรับผูใชระบบปฏิบัติการที่ตางชนิดกัน การติดตั้งโปรแกรมก็ทํ าไดไมยาก  ซ่ึง
สามารถดาวนโหลดไดที่ www.Atmel.comโดยใหทานคลายไฟล Astudio4(zip file)ออกมา จากนั้น
ก็รันไฟล setup.exe และกท็ ําตามขั้นตอนที่แนะนํ าไปเรื่อยๆ จนการติดตั้งเสร็จสมบูรณ ซ่ึงหลังการ
ตดิตัง้โปรแกรมนี้มันก็พรอมที่จะทํ างานทันทีโดยเราไมตองเสียเวลารีสตารตเครื่องใหม
System requirement

- โปรแกรมนี้รันบนระบบปฏิบัติการ windows 9x/ME/NT/2000/XP
- ความเร็วของ CPU Intel Pentium 200 MHz
- ความละเอียดหนาจอไมควรตํ่ ากวา 800x600 pixels
- แรม 64 MB
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- ทีว่างฮารดดิสก 15 MB ขึ้นไป
1.1 การสรางไฟลโปรเจ็กตและไฟลอ่ืน ๆ

ถาการติดตั้งถูกตอง เมื่อเราเปดโปรแกรมนี้ขึ้นมา เราจะพบหนาตาง Welcome to
AVR Studio4 ดังนี้

สามารถเป
จะแสดงเป
สามารถท
มือของหน
ตอไปทาน
ออปชั่น P
โปรเจ็กตใ
นี้
ภาพประกอบ ก1 หนาตาง Welcome to AVR Studio 4

หนาตางนี้จะมีไวสํ าหรับใหเราสามารถทํ าการสรางโปรเจ็กตไฟลใหมหรือ
ดโปรเจ็กตไฟลที่มีอยูแลวได โปรเจ็กตไฟลจะมีนามสกุลเปน .aps สํ าหรับหนาตางนี้มัน
นอันดับแรกของการเปดโปรแกรมทุกครั้ง หากเราไมตองการใหมันแสดงหนาตางนี้ เรา
ํ าไดโดยการคลิกเมาส 1 คร้ังที่เช็คบล็อกShow this dialog on open ทีอ่ยูทางดานลางซาย
าตางนี้ เพื่อเอาเครื่องหมายถูกที่กาอยูในเช็คบล็อกออกไป ซ่ึงในการเปดโปรแกรมครั้ง
จะไมพบหนาตางนี้อีก และการเปดหรือสรางโปรเจ็กตใหมเราสามารถทํ าไดผานทาง
roject ทีอ่ยูในเมนูบารแทน แตสํ าหรับการอธิบายในที่นี้เราจะใชหนาตางนี้ในการสราง
หม โดยใหทานคลิกที่ปุม Create New Project ซ่ึงทานจะพบกับหนาตางใหมดังรูปตอไป
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โปรแกร
File จาก
โปรเจ็ก
ช่ือไฟล
แอสเซม
สามารถ

คอมไพ
ตั้งชื่อไฟ
จะไดไฟ

สามารถ
เช็คบ็อก
ชองขอค
เกบ็ไฟล
         ภาพประกอบ ก2 หนาตางทีใ่ชในการสรางโปรเจ็กตไฟล

ในขณะที่ทํ าการสรางไฟลโปรเจ็กต โปรแกรมสามารถที่จะสรางไฟล .asm ซ่ึงเปนไฟล
มภาษาแอสเซมบลีไดพรอมกันไปในตัวโดยการกาเครื่องหมายถูกที่เช็คบ็อก Create Initial 
นั้นใหเราพมิพช่ือไฟลโปรเจ็กตที่ชองขอความ Project Name ในตวัอยางเราจะใชช่ือไฟล
ต rs232 และในระหวางที่เราพิมพช่ือไฟลโปรเจก็ต เราจะสังเกตุเห็นวาโปรแกรมจะพิมพ
โปรเจ็กตลงที่ชองขอความ Initial File ไปดวย ซ่ึงจะเปนการสรางไฟลโปรแกรม .asm (ไฟล
บลี) และหากเราตองการใหโปรแกรมสรางไฟล .asm ทีม่ช่ืีอตางจากชื่อไฟลโปรเจ็กต เราก็
แกไขชื่อไฟล .asm ไดที่ชองขอความ Initial File นี้
ขอควรระวังในการตั้งชื่อไฟลแอสเซมบลีตางจากชื่อไฟลโปรเจ็กตนั่นก็คือ เมื่อเราทํ าการ
ลแลวไฟลตางๆ ทีโ่ปรแกรมทํ าการสรางขึ้นมามันจะตั้งชื่อตามชื่อไฟลโปรเจ็กตเชน ถาเรา
ลโปรเจ็กตเปน Testproject และเราตั้งชื่อไฟลแอสเซมบลีช่ือ rs232 หลังการคอมไพลเรา
ล Testproject.hex ดงันี้เปนตน
หากเราไมตองการใหมันสรางไฟลโปรแกรม .asm ขึน้ในขณะที่เราสรางไฟลโปรเจ็กต เรา
ทํ าไดโดยการคลิกที่เช็คบ็อก Create Initial File เพือ่เอาเครื่องหมายถูกที่กาอยูออก สวนที่
 Create Folder จะเปนการสรางโฟลเดอรขึ้นมาเพื่อเก็บไฟลโปรเจ็คไวนั่นเอง ถัดลงมาที่
วาม Location จะเปนตํ าแหนงของไฟลโปรเจ็คที่จะถูกนํ าไปเก็บ ซ่ึงเราสามารถเลือกที่จะ
ที่ใหมไดโดยการคลิกที่ปุม  ทีอ่ยูทายชองรับความหรือพิมพช่ือ path ลงไปเลยก็ไดเชน
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เดยีวกนั สํ าหรับในตัวอยางนี้เราจะเก็บไฟลโปรเจ็กตไวที่ C:\My Documents\avr และทํ าการสราง
ไฟล .asm ขึน้พรอมกับการสรางไฟลโปรเจ็กตดวย

เมื่อทุกอยางถูกตองดีแลวก็ใหเราทํ าการคลิกที่ปุม Finish เพื่อจะเขาหนาจอ text editor 
สํ าหรับเขียนโปรแกรมตอไป หนาจอที่เกิดขึ้นใหมหลังการกดปุม Finish แสดงไดดังรูปตอไปนี้ 
(ถาเรากดปุม Next โปรแกรมจะใหเราเลือก paltform และ MCU ทีเ่ราจะใชในการซมิมูเลตและ  
debug โปรแกรม ตอไป)

จ
ไฟลในโป
หนาตางถ
Output ท
พบหนาต
Work space
ภาพประกอบ ก3 หนาจอ

ากภาพประกอบ ก3 จะประกอบไปดวยห
รเจ็กตเชนการ Add existing file, Remov
ัดมาคือ Text Editor มไีวสํ าหรับใหเรา
ีท่ ําหนาที่แสดงขอความบอกใหเราทราบถ
างทั้งสามนี้ทานสามารถเปดมันขึ้นมาไดเอ
Text Editor
ที่เ

น
e 
เข
ึงผ
ง

Output
กิดขึ้นหลังการกดปุม Finish

าตาง Work space ซ่ึงมีไวสํ าหรับจัดการกับ
File หรือ การ Set as Entry File เปนตน สวน
ียนโปรแกรมลงไป และสุดทายเปนหนาตาง 
ลจากการคอมไฟลโปรแกรม ซ่ึงหากทานไม

 โดยการเขาไปเลือกที่เมนู View
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เมื่อเราทํ าการเขียนโปรแกรมลงไปที่ text editor เรียบรอยแลวก็ใหทํ าการบันทึกไฟลโดย
การเลือกไปที่เมนู File>save และทํ าการคอมไพลโปรแกรมโดยการกดปุม F7 หรือเลือกที่เมนู 
Project>Build หากเราเขียนโปรแกรมถูกตอง โปรแกรมจะไมฟอง Error ทีห่นาตาง Output แตหาก
เขยีนโปรแกรมไมถูกตองมันจะฟอง Error หรือ Warning กใ็หเราแกไขมันใหถูกตองและทํ าการ
คอมไพลใหมซ่ึงจะทํ าใหไดไฟล rs232.aps, rs232.hex, rs232.lst, rs232.map, rs232.asm และ 
rs232.obj ขึ้นมา หากเราไมตองการไฟล .map และ .lst ใหเราเขาไปที่เมนู Project>AVR Asembler 
Setup จากนั้นจะพบหนาตาง AVRAssembler  ใหเราคลิกเอาเครื่องหมายถูกที่ชอง Map File กับ Lst 
File ออกและจากนั้นก็กดปุม Ok กเ็ปนอันเสร็จสิ้น สํ าหรับไฟลนามสกุลตางๆ ดังที่เรากลาวมาขาง
ตนทานสามารถเปดเขาไปดูเนื้อหาขางในไฟลไดดวยการเลือกไปที่เมนู File>Open File จากนั้นก็
เลือกไฟลที่ทานตองการเปดและกดปุม Open

     ภาพประกอบ ก4 หนาตาง AVRAssembler
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1.2 การเปดไฟลโปรเจ็กตและไฟลแอสเซมบลี
เมื่อเราตองการเปดโปรแกรมที่มีอยูแลวขึ้นมาแกไขเราสามารถทํ าไดโดยการคลิก

เมนู Project>Open Project เพือ่เปนการเปดไฟลโปรเจ็กต(*.aps) หลังจากที่เราเปดไฟลโปรเจ็กต
แลวจากนั้นก็คลิกเลือกไปที่โฟลเดอร Assembler ทีอ่ยูในหนาตาง Work space เราจะพบไฟล .asm 
ทีเ่ราตองการแกไขอยูในนั้น แตถาหากเราเปดไฟลโดยใชเมนู File>Open File เราก็สามารถที่จะเปด
ไฟล .asm(หรือไฟลอ่ืนๆ ที่ text editor รองรับ) ไดเชนเดียวกัน แตเราจะไมสามารถทํ าการคอมไพล
มันได เปนไดแตเพียงการแกไขและบันทึกเทานั้น อยางไรก็ตามการเปดไฟลโปรเจ็กต(*.aps) ดวย
เมนู File>Open File นี้ก็สามารถทํ าไดและใหผลการทํ างานเชนเดียวกับการเปดมันดวยเมนู
Project>Open Project

1.2.1 การ Add existing File, Remove File และ Set as Entry File
- Add existing File กค็อืการเพิ่มไฟล .asm เขามาในโปรเจ็กต โดยเรา

สามารถทํ าได 2 วิธีดวยกันคือการเลือกไปที่เมนู Project>Add existing File จากนั้นก็ใหเราเลือก
ไฟล .asm ที่เราตองการนํ าเขามา สวนอีกวิธีหนึ่งทํ าไดโดยการคลิกเมาสปุมขวาไปที่โฟลเดอร 
Assembler ทีอ่ยูในหนาตาง Work space จากนัน้เราจะเห็นหนาตางออปชัน่เล็กๆ ปรากฏขึ้นมาก็ให
เราเลื่อนเมาสไปคลิกเลือกที่ Add existing File จะทํ าใหเราสามารเลือกไฟล .asm ที่เราตองการได

- Remove File จะทํ างานตรงกันขามกับ Add existing File นัน่คือมันจะ
ลบไฟล .asm ทีเ่ราไมตองการออกจากโปรเจ็กตไฟลของเรา เราสามารถ Removeไฟลไดโดยการ
คลิกเมาสปุมขวาเลือกไปที่ไฟลที่เราตองการลบ จากนั้นจะปรากฏหนาตางขึ้นมาใหเราเลือกไปที่ 
Remove File form Project เพยีงเทานี้ไฟลที่เราเลือกมันก็จะถูกลบออกไปจากโปรเจ็กตที่เรากํ าลัง
ทํ างานอยู

- Set as Entry File จะเปนการเลือกไฟล .asm ทีอ่ยูในโปรเจ็กตไฟลขณะ
นัน้ใหมันพรอมที่จะถูกคอมไพล ฟงกช่ันนีจ้ะมีความจํ าเปนมากเมื่อเรามีไฟล .asm หลายไฟลอยูใน
โปรเจ็กตเดียวกัน ซ่ึงโปรแกรม Astudio4 นีจ้ะไมทํ าการคอมไพลไฟล .asm ทัง้หมดพรอมกัน แต
จะเลือกคอมไพลเฉพาะไฟลที่โดน Set as Entry File เทานั้น เราสามารถรูไดวาไฟล .asm ตวัใดที่ถูก 
set ไวโดยการสังเกตไอคอนที่อยูหนาชื่อไฟลจะมีรูปลูกศรสีแดงหันหัวลงดังนี้  หรือดูไดจาก
ภาพประกอบ ก5
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ภาพ
         
         

จะตอ
เสร็จ 
ตามใ
มนัจะ
ไฟล .

ไรบา
ขนาด
โปรแ
“C:\M
detect
ประกอบ ก5 หนาจอที่เกิดจากการ Add existing File และหนาตาง Output ที่รายงานผลการ
                       คอมไพลโปรดสังเกตการ Warning (วงกลมสีเหลือง) ตางๆดวย ถึงแมการ
                       คอมไพลไมผิดพลาดแตอาจจะมีผลตอการทํ างานของ CPU ได

สํ าหรับการ Set as Entry File สามารถทํ าไดโดยการคลิกเมาสปุมขวาเลือกไปที่ช่ือไฟลที่เร
งการคอมไพลจากนั้นจะปรากฏเมนูเล็กๆ ขึ้นมาใหเราเลือกไปที่ Set as Entry File กเ็ปนอัน
เราควรจํ าไวอยางหนึ่งวาหลังการคอมไพลแลวไมวาเราจะทํ าการคอมไพลไฟล .asm ตัวใดก็
นโปรเจ็กตนั้น ไฟลเอาพุตที่โปรแกรมสรางขึ้นมานั้นจะมีช่ือตามชื่อไฟลโปรเจ็กตนั้นเสมอ 
ไมมีช่ือไฟลตามไฟล .asm ทีถู่กคอมไฟล ดังนั้นเพื่อปองกันการสับสนทานอาจจะใหมีเพียง
asm เพยีงไฟลเดียวอยูในไฟลโปรเจ็กตแตละโปรเจ็กตก็ไดและตั้งชื่อใหทั้งสองไฟลนี้ตรงกัน
อีกอยางหนึ่งที่อยากจะใหสังเกต นั่นก็คือผลที่ไดจากการคอมไพลในแตละครั้งวาเปนเชน

งเชน ขนาดของไฟลที่คอมไพลไดมีขนาดเทาไรซึ่งบางทีเราเขียนโปรแกรมเพลินมันอาจจะมี
โตกวาหนวยความจํ าที่จะเก็บมันก็ได หรือที่สํ าคัญอีกอยางหนึ่งก็คือขอความ Warning ที่
กรมเตือนดังนี้
y Documents\avr\rs232.asm(92): warning: A .db segment with an odd number of bytes is
ed. A zero byte is added.”
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หากทานใดเคยเลน AVR และใชฟงกช่ันที่เกี่ยวกับพอรตอนุกรม RS232 คงพอจะทราบดี
วาบางครั้ง AVR มันก็ไมสามารถแสดงขอความที่อยู หลังบรรทัดนี้(บรรทัดที่แสดงขอความ 
Warning) ตอไปได ทั้งที่ขอความยังไมส้ินสุด นัน่เปนเพราะวามันจะทํ าการเขียนขอมูลลงหนวย
ความจํ าโปรแกรมเปนทีละ word(2 ไบต) ดงันัน้เมือ่ขอความที่เราตองการจะเขียนลงบนหนวยความ
จ ํามนัมีจํ านวนเปนเลขคี่ มันก็จะเพิ่มเลข 0 เขาไปทายขอความในบรรทัดนั้นๆ เพื่อใหครบจํ านวน
เปนเลขคูเสมอ  ทนีีเ้มื่อเราเขียนโปรแกรมใหตรวจสอบขอความวาถาพบเลข  0 เมื่อใดก็ใหถือวาสิ้น
สุดขอความทันที ดังนั้นเมื่อโปรแกรมทํ าการอานและตรวจสอบขอมูลมาถึงไบตที่ AVR เพิ่มเลข 0 
ขึ้นมาเอง โปรแกรมก็เขาใจวาเราตองการสิ้นสุดขอความที่บรรทัดนี้ดังนั้นจึงทํ าใหขอความที่เหลือ
ไมถูกตรวจพบนั่นเอง และวิธีแกงายๆ นั่นก็คือใหเราเพิ่มอักขระอะไรก็ไดเขาไปอีกตัวหนึ่งใน
บรรทัดนี้ยกเวนเลข 0 เทานี้ก็สามารถแกการ warning ตรงนีไ้ด(เลข 0 ที่เรากํ าลังพูดถึงกันอยูขณะนี้
ไมใชเลข “0” ที่เปนรหัส ASCII นะครบัหากแตเปนเลข 0 ที่เปนเซตของเลขจํ านวนเต็ม)

2. แนะนํ าการใชโปรแกรม w95s8535v5
สํ าหรับในหัวขอนี้จะอธิบายถึงวิธีการใชงานโปรแกรม w95s8535v5 เวอรช่ัน 5 โดยจะ

อธิบายวิธีการดาวนโหลดโปรแกรมที่ผานการคอมไพลโปรแกรมแลวลงบนชิปเพื่อใชงานตาม
ความตองการของผูใช

สํ าหรับโปรแกรมนี้สามารถทํ างานไดบนวินโดวส 9x/ME/NT/2000/XP ดังนั้นจึงไมมี
ปญหาใดๆสํ าหรับผูใชระบบปฏิบัติการที่ตางชนิดกัน ซ่ึงโปรแกรมดังกลาวเปนของบริษัทอีทีที 
สามารถดาวนโหลดไดที่ www.ett.co.th การตดิตั้งโปรแกรมก็ทํ าไดไมยาก หลังจากดาวนโหลด
ไฟลเสร็จแลว สามารถรันโปรแกรมใชไดทันที่ โดยในการรันโปรแกรมใชคร้ังแรก จะตองเซ็ต
เลือกตํ าแหนงพอรตสํ าหรับการโหลดโปรแกรมใน Frame Static ในภาพประกอบ ก6 ไดเลือกใช
พอรต Lpt1
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ภาพประกอบ ก6 แสดงหนาตางโปรแกรม w95s8535v5

สํ าหรับหนาตางนี้มันจะแสดงเปนอันดับแรกของการเปดโปรแกรมทุกครั้ง หลังจากนั้น
เลือกคลิกปุม                       ซ่ึงจะแสดง Path ของ window ขึน้มาจากนั้นทํ าการเลือกไฟล
โปรแกรมที่คอม
โปรแกรมในสวน
ซ่ึงหมายความวา

Set port
Lpt1
  

ไฟลแลว ซ่ึงไฟลจะมีนามสกุลเปน .HEX  หลังจาก Open Hex File แลวหนาตาง

 Text ดานลางสุดจากที่แสดงขอความ 0% จะแสดงขอความ Load Hex File Ok 
 โปรแกรมพรอมที่จะทํ าการโหลดไฟลลงบนอุปกรณแลว
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ภาพประกอบ ก7 แสดงหนาตางเมื่อทํ าการ Open File .Hex

หลังจากที่ทํ าการเปดไฟล .Hex เสรจ็เรียบรอยแลวก็มาถึงขั้นตอนการโหลดโปรแกรมลง
บนชิพ ซ่ึงจะตองทํ าการตรวจสอบการตอพอรตและเปดไฟเลี้ยงจายแกบอรดอุปกรณใหเรียบรอย 
หลังจากนั้นกดปุม                        เพือ่ทํ าการโหลดโปรแกรมลงบนชิพเพือ่นํ าไปใชงานตอไป ใน
ขบวนการโหลดเมื่อโปรแกรมโหลดขอมูลเสร็จจะแสดงขอความบอกดังภาพประกอบ

ภาพประกอบ ก8 แสดงหนาตางเมื่อโหลดโปรแกรมลงบนชิพ

Open File .Hex
Ok
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ภาคผนวก ข โปรแกรมรหัสตนฉบับภาษาแอสแซมบลี้สํ าหรับการออกแบบควบคุม

ลํ าดับการแสดงโปรแกรมรหัสตนฉบับของการออกแบบมีดังนี้
1. สวนควบคุมการสรางสัญญาณใหพอรตขนานในโหมดการทํ างานแบบ EPP

(EPPSigCntl)
2. สวนการสรางสัญญาณควบคุมโหมดการเขียนและอาน ADC
3. สวนการรับและสงขอมูลดิจิตอลเขาสูเครื่องคอมพิวเตอรผานพอรตขนาน
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การนิยามตํ าแหนงรีจิสเตอรอินพุทเอาทพุท (I/O Register Definitions)
ในการพัฒนาโปรแกรมจะมีการอางชื่อไฟล (File name) เร่ิมตนกอนที่จะเขียนโปรแกรม

พฒันางานตามความตองการของผูใชคือไฟล "8535def.inc" โดยในการพัฒนาโปรแกรมจะเริ่มตน
โปรแกรมคือ .include "8535def.inc" ซ่ึงหมายถึง การรวมไฟล  "8535def.inc" ทั้งหมดเขาใน
โปรแกรมนี ้ โดยในไฟลนี้จะประกอบไปดวย การนิยามคาตํ าแหนงตางๆของรีจีสเตอรอินพุทเอาท
พทุ โดยตํ าแหนงของชื่อรีจสิเตอรจะนิยามคาเปนเลขฐาน 16 (hexadecimal)  และตํ าแหนงของบิท
จะนยิามคาเปนเลข 0-7 โดยรายละเอียดการนิยามตํ าแหนงรีจิสเตอรอินพทุเอาทพุทมีดังนี้

;***** I/O Register Definitions******
.equ SREG = $3f
.equ SPH = $3e
.equ SPL = $3d
.equ GIMSK = $3b
.equ GIRF = $3a
.equ TIMSK = $39
.equ TIFR = $38
.equ MCUCR = $35
.equ MCUSR = $34
.equ TCCR0 = $33
.equ TCNT0 = $32
.equ TCCR1A = $2f
.equ TCCR1B = $2e
.equ TCNT1H = $2d
.equ TCNT1L = $2c
.equ OCR1AH = $2b
.equ OCR1AL = $2a
.equ OCR1BH = $29
.equ OCR1BL = $28
.equ ICR1H = $27
.equ ICR1L   = $26
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.equ TCCR2 = $25

.equ TCNT2 = $24

.equ OCR2 = $23

.equ ASSR    = 22

.equ WDTCR = $21

.equ EEARH = $1f

.equ EEARL = $1e

.equ EEDR = $1d

.equ EECR = $1c

.equ PORTA = $1b

.equ DDRA = $1a

.equ PINA = $19

.equ PORTB = $18

.equ DDRB = $17

.equ PINB = $16

.equ PORTC = $15

.equ DDRC = $14

.equ PINC = $13

.equ PORTD = $12

.equ DDRD = $11

.equ PIND = $10

.equ SPDR = $0f

.equ SPSR = $0e

.equ SPCR = $0d

.equ UDR = $0c

.equ USR = $0b

.equ UCR = $0a

.equ UBRR = $09

.equ ACSR = $08

.equ ADMUX  = $07
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.equ    ADCSR  = $06

.equ    ADCH    = $05

.equ    ADCL    = $04

;***** Bit Definitions*****
.equ INT1 = 7
.equ INT0 = 6

.equ TOIE1 = 7

.equ OCIE1A = 6

.equ OCIE1B = 5

.equ TICIE = 3

.equ TOIE0 = 1

.equ TOV1 = 7

.equ OCF1A = 6

.equ OCF1B = 5

.equ ICF1 = 3

.equ TOV0 = 1

.equ SRE = 7

.equ SRW = 6

.equ SE = 5

.equ SM = 4

.equ ISC11 = 3

.equ ISC10 = 2

.equ ISC01 = 1

.equ ISC00 = 0

.equ CS02 = 2
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.equ CS01 = 1

.equ CS00 = 0

.equ COM1A1 = 7

.equ COM1A0 = 6

.equ COM1B1 = 5

.equ COM1B0 = 4

.equ PWM11 = 1

.equ PWM10 = 0

.equ ICNC1 = 7

.equ ICES1 = 6

.equ CTC1 = 3

.equ CS12 = 2

.equ CS11 = 1

.equ CS10 = 0

.equ PWM2    = 6

.equ    COM21 = 5

.equ    COM20   = 4

.equ    CTC2 = 3

.equ    CS22 = 2

.equ CS21 = 1

.equ    CS20 = 0

.equ AS2 = 3

.equ TCN2UB = 2

.equ OCR2UB  = 1

.equ    TCR2UB = 0
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.equ WDTOE = 4

.equ WDE = 3

.equ WDP2 = 2

.equ WDP1 = 1

.equ WDP0 = 0

.equ EEAR8 = 0

.equ EEWE = 1

.equ EERE = 0

.equ PA7 = 7

.equ PA6 = 6

.equ PA5 = 5

.equ PA4 = 4

.equ PA3 = 3

.equ PA2 = 2

.equ PA1 = 1

.equ PA0 = 0

.equ DDA7 = 7

.equ DDA6 = 6

.equ DDA5 = 5

.equ DDA4 = 4

.equ DDA3 = 3

.equ DDA2 = 2

.equ DDA1 = 1

.equ DDA0 = 0

.equ PINA7 = 7
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.equ PINA6 = 6

.equ PINA5 = 5

.equ PINA4 = 4

.equ PINA3 = 3

.equ PINA2 = 2

.equ PINA1 = 1

.equ PINA0 = 0

.equ PB7 = 7

.equ PB6 = 6

.equ PB5 = 5

.equ PB4 = 4

.equ PB3 = 3

.equ PB2 = 2

.equ PB1 = 1

.equ PB0 = 0

.equ DDB7 = 7

.equ DDB6 = 6

.equ DDB5 = 5

.equ DDB4 = 4

.equ DDB3 = 3

.equ DDB2 = 2

.equ DDB1 = 1

.equ DDB0 = 0

.equ PINB7 = 7

.equ PINB6 = 6

.equ PINB5 = 5

.equ PINB4 = 4
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.equ PINB3 = 3

.equ PINB2 = 2

.equ PINB1 = 1

.equ PINB0 = 0

.equ PC7 = 7

.equ PC6 = 6

.equ PC5 = 5

.equ PC4 = 4

.equ PC3 = 3

.equ PC2 = 2

.equ PC1 = 1

.equ PC0 = 0

.equ DDC7 = 7

.equ DDC6 = 6

.equ DDC5 = 5

.equ DDC4 = 4

.equ DDC3 = 3

.equ DDC2 = 2

.equ DDC1 = 1

.equ DDC0 = 0

.equ PINC7 = 7

.equ PINC6 = 6

.equ PINC5 = 5

.equ PINC4 = 4

.equ PINC3 = 3

.equ PINC2 = 2

.equ PINC1 = 1
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.equ PINC0 = 0

.equ PD6 = 6

.equ PD5 = 5

.equ PD4 = 4

.equ PD3 = 3

.equ PD2 = 2

.equ PD1 = 1

.equ PD0 = 0

.equ DDD6 = 6

.equ DDD5 = 5

.equ DDD4 = 4

.equ DDD3 = 3

.equ DDD2 = 2

.equ DDD1 = 1

.equ DDD0 = 0

.equ PIND6 = 6

.equ PIND5 = 5

.equ PIND4 = 4

.equ PIND3 = 3

.equ PIND2 = 2

.equ PIND1 = 1

.equ PIND0 = 0

.equ SPIF = 7

.equ WCOL = 6

.equ SPIE = 7
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.equ SPE = 6

.equ DORD = 5

.equ MSTR = 4

.equ CPOL = 3

.equ CPHA = 2

.equ SPR1 = 1

.equ SPR0 = 0

.equ RXC = 7

.equ TXC = 6

.equ UDRE = 5

.equ FE = 4

.equ OR = 3

.equ RXCIE = 7

.equ TXCIE = 6

.equ UDRIE = 5

.equ RXEN = 4

.equ TXEN = 3

.equ CHR9 = 2

.equ RXB8 = 1

.equ TXB8 = 0

.equ ACD = 7

.equ ACO = 5

.equ ACI = 4

.equ ACIE = 3

.equ ACIC = 2

.equ ACIS1 = 1

.equ ACIS0 = 0
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.equ    MUX0    = 0

.equ    MUX1    = 1

.equ    MUX2   = 2

.equ    ADPS0   = 0

.equ    ADPS1   = 1

.equ    ADPS2  = 2

.equ    ADIE   = 3

.equ    ADIF   = 4

.equ    ADFR    = 5

.equ    ADSC    = 6

.equ    ADEN    = 7

.def XL = r26

.def XH = r27

.def YL = r28

.def YH = r29

.def ZL = r30

.def ZH = r31

.equ    RAMEND = $20+$40+$1ff    ;Adjust for registers and I/O

.equ INT0addr = $001 ;External Interrupt0 Vector Address

.equ INT1addr = $002 ;External Interrupt1 Vector Address

.equ ICP1addr = $003 ;Input Capture1 Interrupt Vector Address

.equ OC1Aaddr = $004 ;Output Compare1A Interrupt Vector Address

.equ OC1Baddr = $005 ;Output Compare1B Interrupt Vector Address

.equ OVF1addr = $006 ;Overflow1 Interrupt Vector Address

.equ OC0addr = $007 ;Output Compare0 Interrupt Vector Address

.equ OVF0addr = $008 ;Overflow0 Interrupt Vector Address
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.equ SPIaddr = $009 ;SPI Interrupt Vector Address

.equ URXCaddr = $00a ;UART Receive Complete Interrupt Vector Address

.equ UDREaddr = $00b ;UART Data Register Empty Interrupt Vector Address

.equ UTXCaddr = $00c ;UART Transmit Complete Interrupt Vector Address

.equ ACIaddr  = $00d ;Analog Comparator Interrupt Vector Address
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;/*************************************************************************
; Program :Phonocardiogram the external ADC
; Description :convert analog input signal to 8 bit digital output.
; :The digital signal will be send to palalell port.
; Pin description :Digital input pin = PA7-PA0 : Output pin = PD7-PD0 : PC0 = wait : PC1 = WR
; :PB0 = Address strobe : PC2-PC5 Control signal decoder/demultiplexer to
; :G,A,B,C with RD1-RD8
; CPU Control :90S8535
; File name :Multiplex 8 channal.asm
; Assembler :AVR Studio 4.05
;**************************************************************************
.include "8535def.inc"

    .org $000
         rjmp RESET

.def temp  = r19

.equ koo = 0

.equ  kai = 1

RESET:       ldi temp,low(RAMEND)
               Out SPL,temp
            Ldi temp,high(RAMEND)
            Out SPL+1,temp         
;/***********************
; set port
;/***********************  

 ser r16
         out DDRC,r16

 cbi PORTC,koo
 out DDRD,r16
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 out PORTB,r16
 out PORTA,r16 
 ldi r16,0x00

         out DDRA,r16
         out DDRB,r16

 sbi PORTC,kai
 ldi r17,0b11000010
 out PORTC,r17

  ldi r16,0b10100010 ;ch1 start
  mov r1,r16
  ldi r16,0b10100110 ;ch2
  mov r2,r16
  ldi r16,0b10101010 ;ch3
  mov r3,r16
  ldi r16,0b10101110 ;ch4
  mov r4,r16
  ldi r16,0b10110010 ;ch5
  mov r5,r16
  ldi r16,0b10110110 ;ch6
  mov r6,r16
  ldi r16,0b10111010 ;ch7
  mov r7,r16
  ldi r16,0b10111110 ;ch8
  mov r8,r16

 ldi r16,0b01000010 ;ch1 end
 ldi r17,0b11000010 ;ch2
 ldi r21,0b11010110 ;ch3
 ldi r22,0b11011110 ;ch4
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 ldi r23,0b11001110 ;ch5
 ldi r24,0b11011110 ;ch6
 ldi r25,0b11011110 ;ch7
 ldi r26,0b11011110 ;ch8
 ldi r27,0xab
  

;/***********************************
; start convert multiplex 8 chanall
;/***********************************
a:      in     r18,PINB   ;wait logic 0 from palalell port
       cpi    r18,0xfe
     brne  a

 cbi  PORTC,kai ;ch1
 sbi  PORTC,kai ;write complet
 rcall  delay ;delay time 1.5us

b:  in           r18,PINB
         cpi         r18,0xfe
     brne  b

 out  PORTC,r1 ;start read
 nop
 nop
 nop
 In  r20,PINA ;read data r20
 out  PORTC,r16
 out  PORTD,r20 ;sent data to palalell ch1
 sbi  PORTC,koo
 cbi  PORTC,koo

c:  in    r18,PINB
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        cpi     r18,0xfe
     brne  c

 out PORTC,r2 ;ch2
 nop
nop
nop
in r20,PINA
out PORTC,r17
out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo

d: in     r18,PINB
        cpi     r18,0xfe
    brne  d

out  PORTC,r3 ;ch3
nop
nop
nop
in   r20,PINA
out   PORTC,r21
out   PORTD,r20
sbi   PORTC,koo
cbi   PORTC,koo

e: in       r18,PINB
        cpi      r18,0xfe
    brne   e

out   PORTC,r4 ;ch4
nop
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nop
nop
in  r20,PINA
out PORTC,r22
out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo

f: in           r18,PINB
      cpi         r18,0xfe
    brne f

out PORTC,r5 ;ch5
nop
nop
nop
in r20,PINA
out PORTC,r23
out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo

g: in   r18,PINB
        cpi   r18,0xfe
   brne g

out PORTC,r6 ;ch6
nop
nop
nop
in r20,PINA
out PORTC,r24
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out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo

h: in     r18,PINB
        cpi    r18,0xfe
    brne h

out PORTC,r7 ;ch7
nop
nop
nop
in r20,PINA
out PORTC,r25
out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo

i: in     r18,PINB
        cpi  r18,0xfe
    brne i

out PORTC,r8 ;ch8
nop
nop
nop
in r20,PINA
out PORTC,r26
out PORTD,r20
sbi PORTC,koo
cbi PORTC,koo
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out PORTD,r27 ;sent ab
sbi PORTC,koo
cbi PORTC,koo
rjmp a

;/*************************
; delay time
;/*************************
delay : nop

nop
nop
nop
nop
ret
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ภาคผนวก ค.
ผลงานทาวิชาการ
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บทความเรื่อง

การพฒันาเครื่องตนแบบเพื่อเก็บบันทึกและวิเคราะหเสียงการเตนของหัวใจ
จากหลายตํ าแหนงบริเวณหนาอก

Development of a Prototype System for Recording and  Analysising of  Simultaneous
Phonocardiograms from Multiple chest sites.

  น ําเสนอในการประชุมเสนอผลงานวิจัยระดับบัณฑิตศึกษา มหาวิทยาลัยสงขลานครินทร คร้ังที่ 2
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